Error: "Someone else is already logged on using this user ID" when opening the data file


Summary

  • Displays Error: "Someone else is already logged on using this user ID".
  • Displays Error: "Someone else is already using the program under this name".
  • Displays Error: "Username/Password is already being used by another application."
  • Computer crashed or had power failure while in use.
  • Sage 50 crashed or closed unexpectedly while in use.
  • Computer is on wireless/external network and lost connectivity to the server while in use.
  • I am trying to switch to Single-User mode, but I get an error message "Other users are currently working with this company. You may open the company in multi-user mode or wait for the other users to stop using the company and try again." But I am sure no one else using the company file
  • I am unable to change to single user mode to create a backup.
  • I can't exit / leave out of multi user mode
  • Message: "Another user is currently working with this company on this computer. Please wait for the other user to stop using this company and try again."

Cause

Session ended incorrectly or connection manager lost connection and locked up the User ID on host computer.

Resolution

Note: Before following the resolutions below please check if there is an icon of Sage 50 on the Windows taskbar. It is possible the you have opened the same file earlier and forgot to close it and now you are trying to reopen the same file again. Please advise all users to log out of Sage 50 before proceeding.

Solution I:
Try to login as Sysadmin, Single user mode.
Solution II:
  1. Close Sage 50 on all the computers.
  2. Open Windows Task Manager of the computer hosting the database.
  3. Select the Process tab.
  4. Check the Show processes from all users button.
  5. End any mysqld.exe (or mysqld-nt.exe) from Image Name list.
  6. Open your data file again.

Note: mysqld-nt.exe is from any version prior to 2014.

Solution III: Restart the Connection Manager

  1. Close Sage 50 on all the computers.
  2. Press the Windows key + R
  3. Type services.msc
  4. Find the Sage 50 Database Connection Manager
  5. Right-click and Restart
Solution IV: Delete the file "process.pid"
  1. Check the SAJ folder of the company file for the process.pid file and delete it.
  2. Open your data file again.

Solution V: Reboot the Host PC/Server

  1. Close Sage 50 on all the computers.
  2. Restart the computer hosting the database.
  3. Open your data file again.

Solution VI: Modify Connection Manager settings (for larger networks)

  1. Open Connection Manager from the Taskbar
  2. Under Advance Database Settings modify Memory buffer size from 56 to 256
  3. Under Advance Database Settings modify Number of connection attempts from 4 to 6
  4. Open your data file again.

Solution VII: Workaround - There is no current access to the data storage location (server)

  1. Make sure that there are no other users are logged into and accessing the problem Sage 50 file
  2. Locate the SAJ folder and .SAI file for the data
  3. Copy the files to a new folder in a different server location path
  4. Delete the old .SAI file from the original location to prevent other users from accessing the old data location in the future.